M84 addresse 67 virker ikke

Her kan du debattere og stille spørgsmål til alt om elektronik og digitaldrift på modeljernbanen. Skal du have hjælp til en dekoder eller driller signalet? Stil dit spørsmål her.
Niels
Stationsbetjent
Indlæg: 49
Tilmeldt: 26 maj 2016, 21:48
Digital: Ja
Scale: H0 - 3-rail
Skinnesystem: Märklin C
Geografisk sted: Odense
Kontakt:

Re: M84 addresse 67 virker ikke

Indlæg af Niels » 06 sep 2018, 08:40

Hej Preben,
jeg blander mig lige i sagen nok en gang...
Du skriver, at dekoderne anvendes til at styre banestrømmen til stopsektioner på anlægget. Bare lige for at jeg har forstået helt - har du gennemtestet kredsløbet for den stopsektion, der fejler? Dvs. ligger fejlen eventuelt i "vejen ud til skinnerne" og slet ikke ved dekoderen? Dette kunne måske forklare, at problemet bliver ved at eksistere, trods omkodning af adresse eller udbytning til en ny dekoder.
Kunne der være en lille kortslutning et sted derude? Eller en "glemt diode" fra et tidligere elektrisk setup af stopsektionen? Eller er sporene helt "nylagte", rent elektrisk? En sådan "diode" kunne måske forklare problematikken med at kommandoen GRØN giver et GRØNT output som ønsket, men at kommandoen RØD giver et samtidigt RØDT og GRØNT uønsket output.
Og er der evt. indsat bremsemodul ved stopsektionen - hvis ja, er dette forbundet fuldstændig korrekt? Og fungerer modulet korrekt?
Måske er jeg helt galt på den ...? :lol:
Mvh
Niels

www.NIELS-MODELTOG.dk
Dansk epoke IVb. Kører med MS2 & CS3.

Lyne Preben
Stationsforstander
Indlæg: 52
Tilmeldt: 05 apr 2016, 14:40
Digital: Ja
Scale: H0 - 3-rail
Skinnesystem: Märklin C
Geografisk sted: Lyne

Re: M84 addresse 67 virker ikke

Indlæg af Lyne Preben » 06 sep 2018, 09:22

Hej Niels,
Det er et nylagt stopafsnit, og alt virker korrekt, nor vi blot forbinder "Banestrømsledningen" (den Røde ledning, som går til det isolerede afsnit) til en anden fysisk port på en hvilken som helst anden dekoder, så jeg tror ikke at der er et "kortslutningsproplem).
Ellers tak for input, det er rart når nogen kommer med et "bud" på en problemløsning.

Mvh
Preben
Märklin c-skinner
CS2, CS3
Fortrinsvis Dansk

Søren
Lokomotivfører
Indlæg: 3809
Tilmeldt: 30 jul 2011, 08:36
Digital: Ja
Scale: H0 - 2-rail
Skinnesystem: Trix C
Geografisk sted: Malling
Kontakt:

Re: M84 addresse 67 virker ikke

Indlæg af Søren » 06 sep 2018, 09:37

Preben,

Prøvede du at tage den omtalte sektion, én m84 og forbinde den alene. Altså uden sammenhæng med kæden af de andre dekodere. De andre dekodere må gerne være tilsluttet, men din fejlende m84 og din sektion skal være forbundet med egen forsyning og ikke i kæde med de andre.

Hvad sker der så?
Med venlig hilsen
Søren

2-skinne med Märklin Digital, tysk forbillede IV, V og VI

ErikL
Lokomotivfører
Indlæg: 336
Tilmeldt: 12 feb 2015, 19:45
Digital: Ja
Scale: N
Skinnesystem: Minitrix

Re: M84 addresse 67 virker ikke

Indlæg af ErikL » 06 sep 2018, 16:47

Det der undre er at det er tallet 67 ?

Nu ved jeg ikke lige hvordan det virker bag ved men er der noget som “går op” i det binært, eller lignende.

Jeg går ud fra at udgangen ikke er forbundet under måling så dekoder må fejlagtig opfatte bregge udgange som aktive
Så logikken må vel være at rød går on hvor grøn forbliver on, så grøn går aldrig i off.

På et tidspunkt lavede jeg en sniffer til DCC hvor jeg kunne se kommandoer i sporet (blot for sjov da jeg laver it)
Det kunne man bruge til at se om der kommer en OFF til adressen på adressen til grøn.

https://rudysmodelrailway.wordpress.com ... h-arduino/
Mvh Erik
-----------------------------
Mini TRIX
Digikeijs 5000 + tilbagemeldinger mm.
TrainController Gold + diverse udvidelser

Søren
Lokomotivfører
Indlæg: 3809
Tilmeldt: 30 jul 2011, 08:36
Digital: Ja
Scale: H0 - 2-rail
Skinnesystem: Trix C
Geografisk sted: Malling
Kontakt:

Re: M84 addresse 67 virker ikke

Indlæg af Søren » 06 sep 2018, 18:49

Det har intet med adressen at gøre. Jeg testede adresse 67 (som beskrevet i et tidligere indlæg). Det virker fint.

Prøv at gøre forsøget med dekoderen monteret alene, med egen forsyning og se om den kan udføre opgaven.
Med venlig hilsen
Søren

2-skinne med Märklin Digital, tysk forbillede IV, V og VI

Anders63
Ledvogter
Indlæg: 192
Tilmeldt: 27 feb 2016, 19:49
Digital: Ja
Scale: H0 - 2-rail
Skinnesystem: Tillig Elite code 83

Re: M84 addresse 67 virker ikke

Indlæg af Anders63 » 06 sep 2018, 19:10

Hej Preben!
En fråga bara...har du haft spänningen på ut till dekodrar medan du ändrade om dipswitchen?
I så fall har du orsakat störning i en dekoder.
Märklin ger strikt ut en varning i manual,om att man ska inte ha spänning på till m83/m84 när man ska koppla in trådar eller ändra om dipswitch.

ErikL
Lokomotivfører
Indlæg: 336
Tilmeldt: 12 feb 2015, 19:45
Digital: Ja
Scale: N
Skinnesystem: Minitrix

Re: M84 addresse 67 virker ikke

Indlæg af ErikL » 06 sep 2018, 20:41

Søren skrev:
06 sep 2018, 18:49
Det har intet med adressen at gøre. Jeg testede adresse 67 (som beskrevet i et tidligere indlæg). Det virker fint.

Prøv at gøre forsøget med dekoderen monteret alene, med egen forsyning og se om den kan udføre opgaven.
Korrekt det havde jeg overset 8-)
Mvh Erik
-----------------------------
Mini TRIX
Digikeijs 5000 + tilbagemeldinger mm.
TrainController Gold + diverse udvidelser

Søren
Lokomotivfører
Indlæg: 3809
Tilmeldt: 30 jul 2011, 08:36
Digital: Ja
Scale: H0 - 2-rail
Skinnesystem: Trix C
Geografisk sted: Malling
Kontakt:

Re: M84 addresse 67 virker ikke

Indlæg af Søren » 06 sep 2018, 21:05

ErikL skrev:
06 sep 2018, 20:41
Korrekt det havde jeg overset 8-)
Det gør selvfølgelig ikke mysteriet mindre mystisk... 🤔
Med venlig hilsen
Søren

2-skinne med Märklin Digital, tysk forbillede IV, V og VI

Anders63
Ledvogter
Indlæg: 192
Tilmeldt: 27 feb 2016, 19:49
Digital: Ja
Scale: H0 - 2-rail
Skinnesystem: Tillig Elite code 83

Re: M84 addresse 67 virker ikke

Indlæg af Anders63 » 08 sep 2018, 10:34

Har du möjligen ändrat om värdena i CV 79?
Du kan också reseta dekodern m84 med CV 8 och skriva värde 8.

Lyne Preben
Stationsforstander
Indlæg: 52
Tilmeldt: 05 apr 2016, 14:40
Digital: Ja
Scale: H0 - 3-rail
Skinnesystem: Märklin C
Geografisk sted: Lyne

Re: M84 addresse 67 virker ikke

Indlæg af Lyne Preben » 09 sep 2018, 16:14

Hej,
Jeg tror ikke at det kan have noget med CV værdi at gøre, da det er præcis samme problem når man tager er helt ny M84 ud af pakken, og monterer den.

Mvh
Preben
Märklin c-skinner
CS2, CS3
Fortrinsvis Dansk

Besvar