M84 addresse 67 virker ikke

Her kan du debattere og stille spørgsmål til alt om elektronik og digitaldrift på modeljernbanen. Skal du have hjælp til en dekoder eller driller signalet? Stil dit spørsmål her.
Niels
Stationsbetjent
Indlæg: 49
Tilmeldt: 26 maj 2016, 21:48
Digital: Ja
Scale: H0 - 3-rail
Skinnesystem: Märklin C
Geografisk sted: Odense
Kontakt:

Re: M84 addresse 67 virker ikke

Indlæg af Niels » 11 sep 2018, 08:31

Hej

Tillader mig lidt reflektioner om m83 og m84 dekodere, her en regnfuld tirsdag morgen. :?
Jeg ved godt, at jeg nu gentager mig selv, men det er da nu stadig lidt underligt, at vi er op til flere brugere der har problemer med m83 og m84 dekoderne - lige netop omkring adresserne 63 og frem... Og alle med CS3'en som styrende enhed.

indeværende tråd

viewtopic.php?f=6&t=2808

viewtopic.php?f=6&t=2356

- Hvad er det vi ikke gennemskuer?
- Er der en "adresse-konflikt" et sted derude vi ikke ser?
- Husker CS3'en noget den ikke skal, trods udførte dekoder-reset eller en direkte fysisk ombytning til anden m83/m84 dekoder?
- En Bug i softwaren på CS3?
- Er det problemet med at have flyttet på kontakterne på dekodernes museklaver, mens der er spænding på, der laver balladen?
Eller noget helt, helt andet....? :?:

Jeg ville ønske, at jeg kunne genskabe mit eget lille problem for bedre at kunne forstå, men dette er ej lykkedes mig.

En smule frustrerende...
Mvh
Niels

www.NIELS-MODELTOG.dk
Dansk epoke IVb. Kører med MS2 & CS3.

Anders63
Ledvogter
Indlæg: 192
Tilmeldt: 27 feb 2016, 19:49
Digital: Ja
Scale: H0 - 2-rail
Skinnesystem: Tillig Elite code 83

Re: M84 addresse 67 virker ikke

Indlæg af Anders63 » 11 sep 2018, 18:00

Då kan det vara en bug i CS3 som är troligen fel inställt av programansvarig hos Märklin.
Ni får rapportera detta till Märklin om andra kunder har också fått samma problem.
Dekodrar m83 och m84 verkar fungera som det ska.
Då är felet i CS3?

moppe
Lokomotivfører
Indlæg: 3123
Tilmeldt: 30 jul 2011, 12:22
Digital: Ja
Scale: H0 - 2-rail
Geografisk sted: Hammel
Kontakt:

Re: M84 addresse 67 virker ikke

Indlæg af moppe » 11 sep 2018, 18:30

Søren har allerede testet en M84 op med CS3:
viewtopic.php?f=6&t=2870&start=20#p17145

Preben skriver i det oprindelige indlæg:
“Sådan virker det på alle adresser, undtagen adr. 67, her skifter dioden som den skal, og man kan høre et "klik" fra M84, men der er stadig spænding på porten, selvom dioden lyser rødt.”

Ergo dekoderen får besked på at skifte, lyset på dekoderen skifter og selv relæet i udgangen klikker.

Altså er der ingen softwarefejl..........


Klaus

Søren
Lokomotivfører
Indlæg: 3809
Tilmeldt: 30 jul 2011, 08:36
Digital: Ja
Scale: H0 - 2-rail
Skinnesystem: Trix C
Geografisk sted: Malling
Kontakt:

Re: M84 addresse 67 virker ikke

Indlæg af Søren » 11 sep 2018, 19:54

En simpel test ville jo så være at Preben gav sin dekoder en adresse langt fra 63. F.eks. 301 (som Niels oplevede fungerede). Hvis teorien er korrekt, så vil Prebens også fungere. Hvis ikke, så ved vi det ikke er årsagen.

Det er da forsøget værd, hvis den mulighed skal udelukkes.

Jeg har ganske korrekt testet adresserummet 63 - 67, og det fungerer uden problemer.

Jeg har dog ikke testet det med det samme antal dekodere i serie, for så mange dekodere har jeg slet ikke til rådighed på testanlægget. Det bør dog også testes, hvis det er antallet der er en afgørende faktor. Så vidt jeg kan se på Niels' opsætning, så benytter du 60822. Så den manglende 60822 på Prebens opsætning bør ikke være problemet.

Jeg ville dog stadig:
1. Fjerne lusen mellem dekoderne og tappe strømmen fra banestrømsporten pr. dekoder. Se om det gør en forskel. Hvis ikke, så skal du forbinde lusene tilbage igen og:

2. Kontrollere dekoderen alene (altså ikke i serie), med adresse 63, kablerne forbundet som det er tanken de skal være. Du skal kontrollere at banestrømmen slukker og tænder som forventet. Det er afgørende for forsøgets succes, at du forbinder dekoderen til anlægget som det oprindeligt var planlagt. Dog uden at den er i serie. Vi tester her om serien er et problem.

Hvis det fungerer, så er der et problem med dekoderne i serie.

Vi kan gætte herfra og til evig tid. Men vi er nødt til at gå systematisk frem i fejlsøgningen, og ikke søge i 100 retninger på samme tid. Hvis det pludselig begynder at virke, finder vi aldrig ud af hvorfor, hvis vi ikke resetter opstillingen efter hver test.

Hvis det viser sig, at dekoderen har problemer når den er serieforbundet, så er næste test at teste udelukkende med m84 i serie. Men den tager vi, hvis det bliver et problem.

Umiddelbart skulle det være mærkeligt, at det skulle have en betydning om dekoderen sidder i serie eller ej. Symptomerne er heller ikke helt de samme som Niels', men det er sammenfald nok til at undre sig. Så nogle tests er en god ting tænker jeg. Om end ikke andet for at få årsager udelukket.
Med venlig hilsen
Søren

2-skinne med Märklin Digital, tysk forbillede IV, V og VI

Lyne Preben
Stationsforstander
Indlæg: 52
Tilmeldt: 05 apr 2016, 14:40
Digital: Ja
Scale: H0 - 3-rail
Skinnesystem: Märklin C
Geografisk sted: Lyne

Re: M84 addresse 67 virker ikke

Indlæg af Lyne Preben » 22 nov 2018, 18:11

Hej igen,
Lige en opdatering på dette problem.
Vi har forsøgt mange forskellige opsætninger, uden at det har løst problemet, og vi har nu konstateret at vi har samme problem med 2 andre dresser længere oppe i rækkefølgen.
Indtil videre har vi opgivet, og blot markeret de pågældende adresser som "Virker ikke".
Jeg har dog konstateret følgende:
Sæt den pågældende port på "RØD", afbryd strømmen til dekoderen, tilslut strømmen igen, Der er nu afbrudt for den røde udgang på den pågældende port. Sæt den på "Grøn", nu er der spænding på porten. Sæt den tilbage på "Rød", og der er stadig spænding på porten, og det vedbliver der med at være indtil man igen slukker/tænder for dekoderen.
Det er meget mærkeligt, da fejlen findes på flere forskellige dekodere. Kan der evt. være "Hardware" fejl på X antal dekodere fra Märklin?
Under alle omstændigheder et det irreterende, og det er jo ikke ligefrem det billigeste isenkram sådan en M84.

Hilsen
Preben
Märklin c-skinner
CS2, CS3
Fortrinsvis Dansk

Søren
Lokomotivfører
Indlæg: 3809
Tilmeldt: 30 jul 2011, 08:36
Digital: Ja
Scale: H0 - 2-rail
Skinnesystem: Trix C
Geografisk sted: Malling
Kontakt:

Re: M84 addresse 67 virker ikke

Indlæg af Søren » 22 nov 2018, 18:48

Jeg tror ikke der er fejl på hardwaren. Det giver ikke rigtig mening for det er "bare" en adresse. Jeg har desuden testet din problematik med netop den nævnte adresse. Jeg kan ikke genskabe problemstillingen.

Jeg er der, hvor en visuel inspektion nok er på sin plads.
Med venlig hilsen
Søren

2-skinne med Märklin Digital, tysk forbillede IV, V og VI

Lyne Preben
Stationsforstander
Indlæg: 52
Tilmeldt: 05 apr 2016, 14:40
Digital: Ja
Scale: H0 - 3-rail
Skinnesystem: Märklin C
Geografisk sted: Lyne

Re: M84 addresse 67 virker ikke

Indlæg af Lyne Preben » 22 nov 2018, 20:17

Hej Søren,
Igen tak for hurtig response.
Med visuel inspektion, mener du så et billede af den pågældende port, monteret med et "Multimeter" som viser at der rent faktisk er spænding på den den er sat på rød, eller hvad tænker du?

mvh
Preben
Märklin c-skinner
CS2, CS3
Fortrinsvis Dansk

moppe
Lokomotivfører
Indlæg: 3123
Tilmeldt: 30 jul 2011, 12:22
Digital: Ja
Scale: H0 - 2-rail
Geografisk sted: Hammel
Kontakt:

Re: M84 addresse 67 virker ikke

Indlæg af moppe » 22 nov 2018, 21:41

Har du en ekstra M84?

I så tilfælde vil jeg gerne teste en af de defekte.



Klaus

Søren
Lokomotivfører
Indlæg: 3809
Tilmeldt: 30 jul 2011, 08:36
Digital: Ja
Scale: H0 - 2-rail
Skinnesystem: Trix C
Geografisk sted: Malling
Kontakt:

Re: M84 addresse 67 virker ikke

Indlæg af Søren » 22 nov 2018, 23:12

Lyne Preben skrev:
22 nov 2018, 20:17
Med visuel inspektion, mener du så et billede af den pågældende port, monteret med et "Multimeter" som viser at der rent faktisk er spænding på den den er sat på rød, eller hvad tænker du?
Jeg kunne godt tænke mig at se det live. Lyne er dog lidt langt væk.

Jeg vil også meget gerne teste en defekt m84.
Med venlig hilsen
Søren

2-skinne med Märklin Digital, tysk forbillede IV, V og VI

Lyne Preben
Stationsforstander
Indlæg: 52
Tilmeldt: 05 apr 2016, 14:40
Digital: Ja
Scale: H0 - 3-rail
Skinnesystem: Märklin C
Geografisk sted: Lyne

Re: M84 addresse 67 virker ikke

Indlæg af Lyne Preben » 27 nov 2018, 16:41

Hej Søren,
Jeg har sendt dig en PB

hilsen
Preben
Märklin c-skinner
CS2, CS3
Fortrinsvis Dansk

Besvar